About the next firmware upgrade.

Our Dev team will soon release the next firmware upgrade.

For all Cybooks (Gen3 and Opus), you will have a possibility to download 2 firmware.

Here are some of the new features that will brighten up your reading experience:

Firmware 1.5: Mobipocket.

Support of Mobipocket prc files.

Support of non DRMed prc and pdf files.

Support of html, txt, jpeg, png, gif.

12 font sizes on all prc, html and txt files.

Rotation of the page and Zoom from 50 to 100%.

Browsing mode : new interface presentation.

Possibility to create your own folders.

Possibility to speed-up the page turn (in library-mode and in a book)

Possibility to zoom / change font size by pressing + or – button (Cybook Gen3), by pressing simultaneously menu and one of the page forward/backward button (Cybook Opus).

Possibility to delete files by pressing delete button (Cybook Gen3), by going through the menu (Cybook Gen3 and Cybook Opus).

Firmware 2.0: Adobe Digital Edition

Support of Adobe Digital Edition epub and pdf files.

Support of non DRMed epub and pdf files.

Support of html, txt, jpeg, png, gif.

12 font sizes on all epub, txt, html files.

Rotation of the page and Zoom from 50 to 100%.

For pdf files: hyperlinks are now activated and the covers are displayed on the library page.

Browsing mode: new interface presentation.

Possibility to create your own folders.

Possibility to speed-up the page turn by maintening the pressure on a page turn button (in library-mode and in a book).

Possibility to zoom / change font size by pressing + or – (Cybook Gen3), by pressing menu and one of the page forward/backward button (Cybook Opus).

Possibility to delete files by pressing delete button (Cybook Gen3), by going through the menu (Cybook Gen3 and Cybook Opus).

We hope that you will enjoy reading with your Cybook even more than before.

Best regards,

Bookeen Team.

49 thoughts on “About the next firmware upgrade.

  1. Thanks for the update.Do I read this right, we must choose between Mobipocket support OR epub support? Or are these updates incremental to the existing feature set?I mean, right now I'm using 1.2 (820) on my Gen3. It reads Mobipocket files. Would updating to 2.0 remove Mobipocket support?

    Like

  2. Hello,Because of a contractual matter beyond Bookeen, one device cannot support two different DRM simultaneoulsy.Nevertheless, you will be able to switch from one firmware to another as much as you want, by installing one of the next firmware on your Cybook. The 2.0 will switch to Adobe DRM, the 1.5 will switch to Mobipocket.Best regards and good reading.Bookeen's Team

    Like

  3. Pity I won't be able to check this update. I just lost my Cybook on a trip abroad. Now I'll have to decide which new reader to buy, and it's a pity I didn't get to test the new firmwares before that.Having to switch firmwares suck, I must say. In general, DRM sucks. I have some Mobipocket books which are now "out of print", so even if I get a new reader which supports Mobipocket I won't be able to download them with the new device's PID.At least this post means that the Opus is an alternative, since the product page doesn't mention Mobipocket, but it looks like I'll be able to switch to it.

    Like

  4. Hello,This also affect, for the moment, the non-DRMed file, except for PDF that was already readable on a Mobipocket firmware.1.5 will not be able to read non-DRMed epub, as 2.0 will not be able to read non-DRMed prc.In order to be able to read one or the other, you will need to upgrade your cybook in one way or the other.Best regards,Bookeen's Team

    Like

  5. That is awful! One of my reasons for choosing the Cybook was that it read both PDF and other types of files – and was looking forward to being able with the new firmware being able to add E-Pub files to that. With the new upgrade to the Mobipocket, will it be able to read PDF's that I already have – created with either Adobe or anothe PDF creator? (not E-Pub).

    Like

  6. Dear Shinken,As for before, mobipocket and epub files will have pages number.The difference is that epub will be able to display it in the status bar,instead of the mobipocket that only show a paginometre.

    Like

  7. Let's not forget that this is down to Adobe not Bookeen. They have offered us alternative firmware to be able to use either, which is the best they are able to do do (and probably more than some other manufacturers would bother to do).Personally I prefer the paginometre over page numbers, is there a choice?

    Like

  8. Dear Steve,In fact it is a problem coming from Mobipocket's contract. For the moment you will not be able to choose between paginometre (prc) and page number (epub).Best regards and good reading to all of you.Bookeen's Team

    Like

  9. Hello,The bookmarks for epub will not be available in the next firmware upgrade. Nevertheless, our team is working on its implementation for a futur upgrade.Best regards,Bookeen's Team

    Like

  10. As previously said, you will not be able to have at the same time both DRM on one device.You will be able to switch from one to another by upgrading your firmware to 1.5 or 2.0.best regards,Bookeen's Team

    Like

  11. So just to be VERY clear:with firmware upgrade 1.5 I canread mobiread non-drm pdfthese are the two things I need. I've stored tons of my research materials on pdf format and my purchased books are all mobi.I just want to be sure.

    Like

  12. Thanks for the information.Can you please clarify something:You mention that to read Mobipocket DRM we should use version 1.5 and for Adobe epub we should use version 1.2You also mentioned that whenever we want to read an epub book, we simply need to load the 2.0 firmware, and when we then want to read a mobipocket drm book, we simply need to load firmware 1.5 Is this correct? Generally when one upgrades the firmware on a device it is difficult to downgrade. Can one really downgrade and upgrade as much as one wants?Will there be any issues of having both epub and mobipocket books on my memory card? Or will one have to keep the differnt book formats separate on different memory cards?Thanks much for your feedback. Really looking forward to the new features.

    Like

  13. Hello,You will be able to upgrade or downgrade as much as wanted.In order to do this operation, you will need to have one SD card for the epub format and another one for the mobipocket.All information about the new firmware will be provided when dowloading it.Best regards,Bookeen's Team

    Like

  14. Please give us, loyal custumors, some hope…We are waiting so long since the exciting anouncement of august 27th. Can we still expect the new firmware-release? There has been a month of radio-silence on blog, so any comment or answer would be fine, just to know Bookeen is still out there working on the firmware.

    Like

  15. Dear users,We are very sorry for the delay in 1.5 (Mobi) and 2.0 (Adobe) firmware's release.We should be able to release it very soon. Indeed, nearly all verifications have been done.Please, be sure that we are doing our very best to provide you with a satisfactory solution.Best regards,Bookeen Team

    Like

  16. Hello,Two weeks ago, I have bought a Cybook Opus.It is version 1.9 (Build 942). So I suppose that in my case the upgrade to 2.0 will not give a lot of additional functionalities. I'm already able to make folders and so on …Maybe someone from the Bookeen team will be able to tell me what "benefit" I will get with the 2.0 firmware ;-)I'm happy with this version but I miss the possibility to make bookmarks with epub doc. I know that this will not be included in the 2.0 upgrade but I continue to hope that this will come later (as soon as possible) because bookmarks is a very important feature for me.Kind regards.Richard.

    Like

  17. I'n eagerly waiting for the upgrade to firmware 2.0 is released. Then I can read ePub format eBooks (the best format there is out there 😉 on my Cybook Gen3Hope it's released soon!

    Like

  18. Dear Bookeen team,In anticipation of the new firmware, I am considering buying an Opus. I would like to clarify the following though:Firmware 2.0 will allow me to zoom .pdf files (and presumably move around using the arrow keys).-> Is that correct?PDF support is quite important for me.Thank you very much for the (soon to come) firmware update service!

    Like

  19. Dear Hans,Yes you are right. You will be able to zoom 10% by 10% from 50% to 100%, see real size, to fit width or height or page, and naviguate inside with the 5 ways button. You will also be able to crop margins.I hope that it gives you the information you needed.With best regards,Bookeen's Team

    Like

  20. I've been holding off on buying a couple of ebooks, because I want to get them in epub format rather than mobi. Can you give me an idea of how long it will be until I can get the firmware to read epub on the Cybook? Thanks,Anita Lewis

    Like

  21. Hello,Since we received a lot of mail asking us when we will be able to release the next firmware upgrade, we would like to assure you that our team is still working on it. As you may have seen, some of your mails might not have been published. The redundancy of their message would not have add valuable information to this blog, which main goals are:- for us: to give you update on our developments and news.- for you: to share your thoughts and to find answer to your requests.While waiting for the firmware upgrade, we wish you a good reading on your Cybooks.With best regards,Bookeen's Team

    Like

  22. Ohhh, I perhaps you meant 1st quarter of 2010 or 2011 or 2012 or 2013. Humm that's not the general understanding by us the owners.What's a wonderful marketing tool. If you can't baffle us with your brillance, you dazzle us with you BS.

    Like

  23. Thanks much for the new firmware.I have tested it with both epub and mobi books and it seems to work great. Really happy that you have enabled the delete button. Really helps to keep my library uncluttered.Keep up the great work and Happy New Year to all the team.CheersGanesh

    Like

  24. Is there any chance of the improved PDF support for non DRM PDF files on the 1.5 firmware? Most of my books are PRC files. I have a few free PDF eBooks that work great under the 2.0 Firmware, but still look like crap on 1.5.

    Like

  25. Hi Fernando,Thanks for your comment! We've gotten quite a lot of interest about an SDK and we are definitely taking these remarks into consideration. You won't see one this year but we are certainly thinking about it. I would love to hear what kind of apps you'd like to develop for your Cybook, don't hesitate to post on facebook or send an email to community[at]bookeen.com, we are always interested to hear how our community is using their Cybooks.To answer your question, yes, the CPU of the Opus is Samsung® S3C2440 (ARM920T core, 400MHz). This is the same as the Gen3 V3.The Gen3 have different CPU depending on the generation:V1 = Samsung S3C2410 @ 200Mhz + 16MB RAM + 64MB internal memory. These are the first Gen3 which were sold, end of 2007.V2 = Samsung S3C2410 @ 200Mhz + 16MB RAM + 512MB internal memory.V3 = Samsung S3C2440 @ 400Mhz + 32MB RAM + 512MB internal memory. This generation arrived end of 2008, beginning of 2009.

    Like

  26. Hello,We are trying to download the "Major Firmware Upgrade 2.0 for Cybook Gen3, Cybook Opus, Cybook Gen3 – Gold Edition (Adobe DRM)" but the link is broken. I've tried a few times now on different days using different browsers with no luck. Please fix the link!

    Like

  27. Hello kmtran33,We're very sorry about your difficulty downloading the firmware update. We're currently updating our website and also putting the final touches on the next firmware update, so some links may not work for a few days. It should all be working smoothly again in a few days.Please send a mail to support[at]bookeen[dot]com and explain your situation, they should be able to help you.We apologise for the inconvience, thanks so much for being patient through these changes!Best regards,The Bookeen Team

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s